Como redireccionar puertos en routers Cisco

Para redireccionar puertos en un router cisco, hay que tener cierta información, el puerto que necesitamos abrir, la ip fija del servidor que queremos abrir a internet, y el puerto que queremos abrir hacía internet.

El comando sería:

ip nat inside source static [tcp/udp] [ip servidor local] [puerto local] interface [Interfaz wan] [puerto exterior]

Un ejemplo para abrir un servidor web:

Router(config)# ip nat inside source static tcp 192.168.1.1 80 interface FastEthernet0/1 80

El puerto 80 del host que tenga la ip 192.168.1.1 será accesible desde fuera de la red local, con lo cual la gente de Internet podrá acceder a nuestra pagina web.

52 comentarios:

  1. Saludos.
    Con una consulta mi estimado. Resulta que echamos mano de este consejo tuyo para publicar un servidor web que está tras un router cisco 2801. El detalle está en que cuando tratamos de ingresar a la IP pública de nuestro sitio, es el router mismo el que contesta (mostrando el prompt solicitando nombre de usuario y contraseña) en lugar de mostrar el servidor (un apache 2.0 sobre linux). ¿Sabes qué es lo que podría estar pasando?
    Te agradecemos de antemano por la atención.

    ResponderEliminar
  2. Hola prueba con esto:


    Router#access-list [lo que quieras] permit [IP red local] [el inverso a la mascara de red]
    Router#line vty 0 4
    config-line#access-group [lo que quieras] in

    Ejemplo:
    Router#access-list 23 permit 192.168.1.0 0.0.0.255
    Router#line vty 0 4
    config-line#access-group 23 in


    Asi conseguiras que a la pagina de administración solo se pueda acceder desde la red interna.Si no te funcionara vuelve a contactar conmigo.

    Saludos y gracias por leerme.

    ResponderEliminar
    Respuestas
    1. Hola Eugenio

      Tengo el mismo problema cuando trato de entrar al servidor web desde dentro y me direcciona al router, ya probe redireccionando con el puerto 80, pero no me ha funcionado

      Eliminar
  3. Gracias por la respuesta Eugenio. Probamos tu solución. De igual manera nos dimos cuenta que si probamos el acceso a la página desde el interior, nos resuelve el router; pero si accedemos desde el exterior, es el webserver quién nos responde. Vamos bien. Ahora ya sólo nos restará encontrar la manera en que el router redireccione a la ip local del webserver cuando la solicitud a la URL de nuestro sitio se haga desde el interior.

    Saludos.

    ResponderEliminar
  4. El problema es que, si rediriges la ip interna, la 192.168.1.(1), le estas diciendo que, todo lo que venga desde la ip publica, vaya a la IP del router.....

    Debes dirigir, lo que venga de la IP Publica, a la IP del servidor donde tengas el host, web, lo que tengas. ej. 192.168.1.33......

    ResponderEliminar
  5. Saludos

    una consulta cuando coloco el comando me sale este error Invalid inputdetected at '^' marker a que se debe me podrias dar una manito gracias de antemano
    me podrias escribir a joseph_20144@hotmail.com

    ResponderEliminar
  6. Buenos Dias,
    Tengo una consulta necesito vizualizar una camara ip de vigilancia desde fuera de mi red local pasando por un router cisco y un firewall SDM podrias darme los pasos a seguir para redireccionar el puerto a la ip de mi camara.

    Gracias

    ResponderEliminar
  7. Necesitaria mas información de como funciona la visualización de la camara, si quieres mandame un mail a eugenio @ mundocisco.com y lo vemos.

    ResponderEliminar
  8. Estimado amigo he seguido tu consejo y gracias dios he podido redireccionar puertos desde afuera , el problema que tengo es que al reiniciar el router aparecen las lineas de redireccion configuradas pero no funcionan , debo borrarlas y crearlas nuevamente para que funciones, que pudeo hacer?

    ResponderEliminar
  9. ¿Como sabes que estan configuradas sino funcionan?

    ResponderEliminar
  10. servidor web detras de router cisco, se puede acceder desde fuera pero no de ninduna de las redes locales de router, como solucionar esto

    ResponderEliminar
  11. tengo un servidor web en mi LAN con un router cisco, internamente no accedo al servidor si coloco la ip publica asociada, externamente si lo hace pero hay veces que debo reiniciar el router por que la conexion externa no se logra.. Auxilio...

    ResponderEliminar
  12. una pregunta como habilito el puerto 80 en un router cisco 2811 plis grax

    ResponderEliminar
  13. Al natear un router series 800. Coloco lo siguiente:
    router (config)#ip nat inside source 192.168.1.14 192.168.150.10
    router (config)#interface fa 1
    router (config-if)#ip nat inside . " AQUI ME SALE EROR" % invalid input detec at `^` marker.
    Alguien me puede ayudar??

    ResponderEliminar
  14. El `^` te indica donde tienes el error exactamente.

    ResponderEliminar
  15. estimado tengo un servidor de audio en la cual ya configarod mi NAT y mis puretos puedo acceder a el como usuario el problema es que en el servidor ahy dos programas de accseso remoto al servidor LOGMAIN Y TEAMVIWEAR ninguno de estos dos se conectan a internet pero puedo navegar en lagunas paginas no en todas
    desde ya gracias

    ResponderEliminar
  16. Tu problema no es del router, o los puertos. Inclusive, si usas logmein no necesitas redireccionar los puertos. Con solo tener internet, ya tienes conexión. Igual con teamviewer. Tu problema es de configuración en el servidor.

    ResponderEliminar
  17. el servidor si lo conecto directo sin pasar por el router cisco 2801 el internet con la ip valida funciona sin problemas logmein y teamviwear pero con el router ya me bloqea esos dos programas de accsesos remotos cualquier idea se lo agradeceria ......

    ResponderEliminar
  18. A ver. Trato de entender tu problema. Si tu configuración de acceso a internet es así:

    Internet <---------> router <----------> PC

    Con esa configuración, sin duda logmein te trabaja perfecto. No tiene nada que ver con tu router. Teamviewer si te podría causar algún inconveniente con tu coreano y los puertos. Que me imagino ya debes tenerlos abiertos para el uso que deseas....

    O no?

    :)

    ResponderEliminar
  19. aver.. redirecciones puertos a unos servidores de audio que estan detrás del router , el usuario puede entrar a mi servidor a buscar los audios
    , pero desde mi servidor no puedo navegar ese es el problema creo q tengo que permitir algun acceso que no tengo idea desde ya se lo agradezco

    Internet <---------> router <----------> PC

    ResponderEliminar
  20. cualquier ayuda se lo agradecería , para que mis servidores puedan navegar...........

    ResponderEliminar
  21. Hola tengo un ruter cisco w2402 de fibertel, necesito abrir el puerto 8000 la empresa se niega a hacerlo, como hago para entrar al ruter y programarlo yo mismo.
    Aclaro que probe con el explorer y la Ip del ruter pero no conecta.
    Alguien sabe como hacerlo.
    Gracias.!!

    ResponderEliminar
  22. Puedes hacerle un reset al router, y configurarlo tu mismo aunque para ello necesitaras un poco de conocimiento y algunos datos de la compañia que seguramente se pueden encontar por internet, tu ip fija si la tienes, etc.

    ResponderEliminar
  23. Gracias Eugenio por la respuesta. Ahora como hago para entrar al router ya que probe colocando la IP de la puerta de enlace y no entra.

    Saludos

    ResponderEliminar
  24. consulta? se me quemo la entrada de consola de mi router y no alcanse a config las vty . abra aluna tarjeta adicional para antara a mi router por consola...

    ResponderEliminar
  25. tengo un router cisco serie 800 y
    telefonica me ha dado una ip publicas 200.48.xxx.xxx, y tengo servidores en los puertos 80 y 82, no tengo acceso a esta ip publicas desde el internet, pero si se pueden acceder desde la intranet, y si se puede navegar. ¿que podria ser?

    interface Ethernet0
    ip address 200.48.xxx.xxx 255.255.255.240
    ip nat inside

    interface Serial0
    ip address 172.22.xxx.xxx 255.255.255.252
    ip nat outside
    encapsulation ppp

    ip route 0.0.0.0 0.0.0.0 172.22.xxx.xxy

    gracias.

    ResponderEliminar
  26. Tengo un router cisco rv082 y necesito encaminar los puertos, el puerto 1025 de la wan lo tengo que cambiar a cualquier otro hacia mi LAN a una IP determinada pero si o si tengo que configurar que el 1025(no se puede modificar en el dispositivo que envía los paquetes) cambia al ser enviado a mi IP privada.
    Gracias

    ResponderEliminar
  27. necesito redireccionar un puerto hacia una ip en la wan donde tengo montado un servidor ssh, mi pc esta detras de un modem y un router cisco, pero no se si tambien el modem se configura o el router ve directamente la ip fija de internet?
    gracias

    ResponderEliminar
  28. Mandame un correo a blog@mundocisco.com con algo mas de información.

    ResponderEliminar
  29. Hola.

    Eugenio se reseteo un Router cisco 850. La configuracion que tenia era que al conectarse via telnet se redireccionaba a un servidor UNIX con esta ip 192.168.0.1...pero ahora no esta funcionando. Cuando doy el telnet me pide el password del Router, y no el login de UNIX...QUE HAGO PARA REDIRRECIONARLO NUEVAMENTE AL SERVIDOR?? PLEAS HELP ME!!!

    ResponderEliminar
  30. Tengo un router RV082 que acabamos de adquirir, anteriormente tenia un router linksys muy facil de configurar el redireccionamiento de puertos solo le decia qeu puerto a que ip del servidor iba, por ejemplo, escribia el puerto 80 para el portal web, con la IP fija del servidor del portal, pero en este modelo nuevo no se como configurar esta parte, alguien me podria explicar como le hago por favor. Gracias.

    ResponderEliminar
  31. Para los que no logran accesar desde la red privada a el servidor web (por ejemplo) que publicaron en el puerto 80 pero si logran verlo desde afuera yo lo solucione agregando a la tabla de host el dominio pero apuntando a la ip interna. Algo asi como

    ip host tusitio.com 192.168.1.2

    espero sirva
    Saludos

    ResponderEliminar
  32. Hola quisiera saber como puedo saber las IP de mi router?. Tengo un router Cisco 2811.

    ResponderEliminar
  33. Para saber las ips de un router cisco, ejecuta este comando
    #sho ip int bri

    Saludos

    ResponderEliminar
  34. Buenas tengo un problema tengo un cisco y compre un blu ray samsun y si conecto el cisco no me sirve el blu ray y viceversa y el puerto que dice Internet le pongo el cable y no entra el Internet que puedo hacer

    ResponderEliminar
  35. Tengo un router Cisco Inalambrico, y tengo una IP en la dmz para que pueda funcionar el servidor WEB, pero internamente no puedo ver el servidor, y la IP no responde, pero desde fuera funciona bn, q puedo hacer.

    ResponderEliminar
  36. Buenas necesito realizar una vpn site to site ipsec, entre un cisco rv180w y cisco 871 con firewall sdm, espero puedas ayudarme.

    ResponderEliminar
  37. Mándame un correo explicándome lo que necesitas.

    ResponderEliminar
  38. Buenas me podrian ayudar para que mi ip publica sea vista desde el interior de mi red local solo la veo desde fuera de mi red ,esta detras de mi router cisco 1800, cual seria los comandos o pasos para habilitarla, claro esta si se puede?

    ResponderEliminar
    Respuestas
    1. Tio sacate un curso, todo el mundo quiere ser informático sin estudiar.

      Eliminar
  39. Buenas, necesitaría ayuda con un router cisco RV 180w , ya que bastante seguido no muestra paginas web y tengo que refrescar con f5 varias veces para que salgan, ya he probado de actualizar el firmware, te aclaro que es una red con 40 equipos y pasa en todos, también cambiamos de provedor isp. desde ya gracias.

    ResponderEliminar
  40. Buenas, tengo un problema a la hora de abrir un servidor del juego Rust.. tengo 200mb contratados con R y un cisco epc3928. Ya tengo configurados los puertos en el forwarding pero tengo algun tipo de problema con el router ya q da lag a la gente q entra en el servidor pero no a mi.. m gustaria saber como resolver ese problema. Un Saludo y Gracias por la atencion.

    ResponderEliminar
  41. Hola, buenos días me podrian ayudar con un problema si se puede claro esta. Mi problema es el siguiente: tengo un router cisco 2911 y quiero configurarlo con una ip publica fija y tengo un servidor en el cual tengo una base de datos y quiero ver esa base de datos conectandome a otra red.

    el diagrama seria masomenos así:

    internet<---->Router<--->pc

    ResponderEliminar
  42. Como acceso al cli del router RV082

    ResponderEliminar
  43. hola tengo un router cisco 350 pero quiero ponerle la clave para que nadie entre a mi red y no puedo configurarlo quien puede ayudarme como puedo hacerlo

    ResponderEliminar
  44. Buenas tardes:

    Tengo un cisco 2901 y una macbook pro, lo que pasa es que despues de un rato me esta desabilitando el puerto donde esta conectado el cable

    me podrian ayudar??

    ResponderEliminar
  45. Hola, mi pregunta es: se puede configurar cisco 1800 via browser? si es asi cómo logro acceder

    ResponderEliminar
  46. Hola, mi pregunta es: se puede configurar cisco 1800 via browser? si es asi cómo logro acceder

    ResponderEliminar
  47. Hola disculpa la molestia, encontré tu nombre por casualidad, estuve buscando información sobre mi módem. Soy italiano y te escribo desde México ,disculpa por mi español, la compañía de Internet me dio el módem Cisco DPC3928S, busco de abrir algunas puertas por emule, se como entrar en la configuración y se como abrir las puertas, pero párese que esto módem no tiene nada adonde cambiar algo, puede Usted ayudarme ?

    ResponderEliminar
  48. Hola espeor me puedan apoyar tego un router cisco rv042g
    y requiero abrir unos puertos para que salgan por internet unas camaras ip que tengo en mi red local, ya probe abriendo desde rutina del firewall incluso desactivandolo... pero nada uso un programa para ridereccionar la ip publica a un host. cuando tecleo el host.. me da la pagina de incio de mi router cosa que me dice que si tiene salida por internet, pero al momento de llamarlo por el puerto asignado a mi camara no me respone nada.. de antemano gracias por suapoyo

    ResponderEliminar
  49. Hola buenas tardes , como puedo abrir los puertos TCP: y HTTP en un router Cisco de antemano gracias .

    ResponderEliminar