Como configurar la dirección ip y el gateway de un switch

switch> enable
switch# configure terminal
switch(config)# ip address 192.168.1.2 255.255.255.0
switch(config)# ip default-gateway 192.168.1.1

Creo que es entendible por si mismo, si alguien tiene alguna duda que pregunte en los comentarios.

53 comentarios:

  1. hola, quiero configurar un switch cisco, pero cuando conecto el cable de consola en el puerto, no me desplega nada en la pantalla de la hiperterminal, el cable si funciona, lo he probado con un router, pero no me despega nada con el switch. tendra dañado el puerto de consola o hay algo que pueda haber bloqueado la conexion por medio de este puerto de consola???. mil gracias por tu respuesta, si sirve de algo el switch es un catalyst 2900 series XL

    ResponderEliminar
  2. Lo unico que se me ocurre es, ¿has probado a presionar teclas cuando conectas el cable?

    ResponderEliminar
  3. estimado no puede ver el swtich 2950 atraves del comado ping hay que hacer alguna configuracion?

    ResponderEliminar
  4. No entiendo la pregunta, puedes explicarla un poco mas, por favor.

    ResponderEliminar
  5. Hola y muchas gracias por las publicaciones, algunas son muy útiles. Tengo un switch 2960 de 24 puertos de cisco en el que las vlan se conectan entre sí pero no consigo conectarle el router, mi gateway es la ip del router, conecto el router le doy de alta al puerto 24 pero algo se me escapa, ¿hay que hacer alguna configuración especial en el puerto 24 o en el switch?

    ResponderEliminar
  6. El puerto donde estan conectandote debe pertenecer a la VLAN 1.

    ResponderEliminar
  7. conoces los ios de los switch para poder usarlos con gns3... solo he conseguido de los router pero necesito los ios de los switch para poder realizar las configuracion si lo tuvieras muchas gracias o me puedes decir donde bajarlo
    mjacksonsr@hotmail.com

    ResponderEliminar
  8. Hola a todos !! les comento que actualmente tengo un Cisco Catalyst 3750G (Layer 3), y querria aprovecharlo para compartir internet y filtrar paquetes. Es posible ello?

    Desde ya, Muchas Gracias !!!
    Saludos CHR !
    chrmark@yahoo.es

    ResponderEliminar
  9. hola---hola.....quisiera saber...como puedo conectar 2 switch a un router.... como tengo que configurar el gateway..???

    ResponderEliminar
  10. Se te olvido : no shutdown

    ResponderEliminar
  11. hola estamos de ruina y no nos como hacerlo, por favor ayunden a unos pobres estudiantes de STI

    ResponderEliminar
    Respuestas
    1. yo ando igual, habremos estudiado en el mismo sitio? jaja

      Eliminar
  12. Mandarme vuestro problema al correo.

    ResponderEliminar
  13. BUENAS ,YO TENGO UN SHICH CATALYS 2960 SERIES USADO , Y QUIERO APRENDER A INSTALARLO Y CONFIGURARLO,PERO NOSE NA DA DE ESTE TEMA, TENGO MUCHAS PREGUTAS,TENGO QUE TENER CONECcION A INTERNET PARA PODER CONFIGURARLO?,TENGO QUE USAR CABLE UTP ESPECIFICO?, BUENO EN FIN ,SI ALGUIEN DE SEA AYUDARME Y ENSEÑARME des de cero LE PAGARE CON DINERO ,SOY
    guzman7125@hotmail.com

    ResponderEliminar
    Respuestas
    1. escribeme y con gusto te ayudo bajor_gx@hotmail.com

      Eliminar
  14. hola....tengo una pregunta....de que me sirve configurar el ip default gateway en un switch capa 2?

    ResponderEliminar
    Respuestas
    1. y tambien...si en el capa 3 asigno una ip a una vlan XX es necesario definir otra ip en la interface vlan XX q se declare en el capa 3

      Eliminar
  15. hola si tengo la ip 172.17.10.1 cual es su gateway?


    porfavor

    ResponderEliminar
    Respuestas
    1. hola el gateway sería 172.17.0.1, pero creo que eso lo va definir si tienes una máscara de subred con clase o sin clase. si la máscara es con clase y es 255.255.255.0 sería clase C el gateway sería 172.17.0.1 pero si es con clase B sería 255.255.0.0 el gateway sería 172.17.0.1. Si es clase A sería 255.0.0.0 el gateway sería 172.0.0.1 Debes tener en cuenta en cual red estás o si perteneces a una subred para definir bien cuál es el gateway

      Eliminar
    2. Si es mascara de 24 bits , ese es el gateway , te invito a que en tu cel. descargues calculadora IP , te va ayudar mucho cuando tengas el tipo de mascara
      Saludos

      Eliminar
  16. Depende, no tiene porque ser fijo, si haces un Ipconfig(en windows) o un ifconfig( en linux) te tiene que poner cual es tu gateway. Si la configuracion la estas haciendo en un switch el gateway sera el router de la red.

    ResponderEliminar
  17. NO SE PUEDE COLOCAR UNA IP AL SWITCH 2960 POR QUE SERA

    ResponderEliminar
  18. hola que tal amigos soy nuevo en esto de publicar en un foro,quiero publicar que todos los comentarios son muy buenos..
    bueno yo les tengo una pregunta espero y puedan ayudarne.. yo estoy configurando un switch cisco sge2000 administrable,gestionable.. quiera saber cono crear vlan por puerto del switch, y que a su vez no piedan los privilegios los segmentos de ip k les asigne.. en otras palabras.. al momento de yo conectar una pc cualquira en un puerto con la vlan mencionada, quisiera k me diera una dirreccion de ese segmento agregado..espero y me de a entender..

    ResponderEliminar
  19. Hola,yo quiero saber como asignarle direcciones ip a un router

    ResponderEliminar
  20. Que tal omar para asignarle direcciones ip a un router cisco solo tenes que meterte ala configuracion de interfaz y agregar la direccion ip y la mascara de subred.

    router>enable
    router#configure terminal
    router(config)#interface fa0/0
    router(config-if)#ip address 192.168.1.1 255.255.255.0

    y luego salis de la configuracion, espero te sirva.

    ResponderEliminar
  21. hola que tal me pudieran ayudar solo tengo que sacar la configuracion de un switch 2960 de 48 puertos que ya esta funcionando pero quieren saber su configuracion como puedo hacer esto
    gracias

    ResponderEliminar
  22. Respuestas
    1. primero tengo que entrar
      digamos
      enable
      configure terminal
      y despues
      show run

      Eliminar
  23. como puedo saber la direccion ip de un cisco inalambrico? sus comentarios serìan de mucha ayuda para mi....

    saludos

    ResponderEliminar
  24. Si estas conectado a la WiFi, tendría que ser tu puerta de enlace.

    ResponderEliminar
  25. BUENOS COMENTARIOS TODOS.
    Tengo el siguiente problema, necesito poner como server dhcp a un switch sfe2010 administrable. por favor ayuda, y cuando conecto el cable srial a mi equipo por el hiperterminal me sale el switch main menu y no me sale el promt en modo consola.

    ResponderEliminar
  26. HOLA SOY ROLANDO CORTEZ DE SAN JUAN ARGENTINA, ME PUEDEN AYUDAR. TENGO UN SWICH CISCO SGE2000 DE 24 PUERTOS Y NO SE QUE HACER CON EL.

    QUIERO ARMAR UNA RED DE 20 COMPUTADORAS Y COMPARTIR INTERNET.

    GRACIAS. UN ABRAZO

    ResponderEliminar
  27. Necesito algo mas de información, ¿como te vas conectar a internet?

    ResponderEliminar
  28. EUGENIO, GRACIAS POR RESPONDER, ME VOY A CONECTAR A INTERNET A TRAVES DE UN ROUTER LINKSYS WRT.
    ME PUEDES AYUDAR A CONFIGURAR ESTE SWICH.
    CISCO SGE 2000
    NO SE, NI SIQUIERA COMO EMPEZAR. SOLO SE QUE LO PUEDO ACCEDER A TRAVES DE 192.168.1.254.
    MI E-MAIL ES: rolando.cortez@yahoo.com.ar

    ResponderEliminar
  29. HOLA BUEN DIA A TODOS, ALGUIEN PODRIA AYUDARME A CONFIGURAR UN SWICH CISCO SGE 2000. DE 24 PUERTOS
    SOY ROLANDO CORTEZ DE SAN JUAN ARGENTINA
    rolando.cortez@yahoo.com.ar

    ResponderEliminar
  30. Que tal sera que alguien me puede brindar información acerca de como puedo configurar una VLAN por default... gracias.

    ResponderEliminar
  31. que manga de wnes mas ignorantes, todo lo puesto aqui esta pesimamente mal, partiendo por el post original,

    switch> enable
    switch# configure terminal
    switch(config)# ip address 192.168.1.2 255.255.255.0
    switch(config)# ip default-gateway 192.168.1.1

    mago ... esto es imposible de realizar, un switch funciona en capa 2 ... no lleva ip, a menos q configures una svi para administrarlo, y en el caso expuesto arriba .... estas colocando la ip en modo de configuracion global ... MAGOO!!!

    ResponderEliminar
  32. Aprovecho que estoy empezando a prepararme para certificar.
    No debería levantar una vlan de administración en switch? Si por ejemplo queremos que la vlan 69 sea la de adm...

    switch> enable
    switch# configure terminal
    switch(config)# interface vlan 69

    %LINK-5-CHANGED: Interface Vlan69, changed state to up
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan69, changed state to up

    ya levantada la vlan de adm se le asigna la ip
    Switch(config-if)# ip address 192.168.1.2 255.255.255.0
    Switch(config-if)# exit

    Ahora asignar ip de gateway de router
    switch(config)# ip default-gateway 192.168.1.1

    Para poder conectar más de una vlan, configurar puerto de switch que conecta a router en modo trunk, y en interfaz de router configurar subinterfaz ( si es la fa0/0 para la vlan 69 sería fa0/0.69) configurar encapsulación y poner la ip da gateway para cada vlan.
    Se aceptan críticas, pero de las constructivas! :D
    Saludos

    ResponderEliminar
  33. se puede dar telefonia ip desde un tp-link tl-sl2452 web a un gateway sin configurar

    ResponderEliminar
  34. hola se que encontraran un poco raro que una mujer este en su foro ya que son puros hombres pero yo estudio redes estoy en practica
    pero no se mucho de configuracion de router y switch sobre todo los de cisco ya que he podido configurar algunos de d-link pero cisco no :( en un switch cuantas vlan se pueden conectar y como se configura vlan espero que me entiendan a lo que me refiero saludos ;)

    ResponderEliminar
    Respuestas
    1. Este comentario ha sido eliminado por el autor.

      Eliminar
  35. No se como llegue aqui, y seguro tu respuesta ya fue resuelta Roxana Labarca: Las VLAN son identificadas por un numero que va del 1 al 4094. Siendo los ID de VLAN 1002 al 1005 reservadas y un switch puede soportar hasta 255 VLANs.

    Se configurar de la siguiente manera:
    switch>enable
    switch#Conf t
    switch(config)# Vlan 10
    switch(config-vlan) name Datos
    switch(config-vlan)exit
    switch(config)# int vlan 10
    switch(config-if)#ip add 192.168.101.10 255.255.254.0
    switch(config-if)#exit
    switch(config)#ip default-gateway 192.168.101.200
    switch(config)#exit
    switch# wr memory
    _______________________________________________________
    UN PUERTO DE SWITCH SOPORTA LA ASIGNACION DE 2 VLAN: Por ejemplo Telefonia/Datos
    interface GigabitEthernet1/0/2
    description "PUERTO DATOS/TELEFONIA"
    switchport access vlan 10
    switchport mode access
    switchport nonegotiate
    switchport voice vlan 40
    srr-queue bandwidth share 1 30 35 5
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    spanning-tree portfast
    spanning-tree bpduguard enable
    service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
    _______________________________________________________
    Saludos espero le sirva a alguien más que ande consultando este blog..... knerlim@gmail.com

    ResponderEliminar
  36. como puedo configurar un switch cisco sge2000p gracias

    ResponderEliminar
  37. Soy nuevo y tengo una duda, como puedo enlazar 1 swich a 3 routers diferentes siendo que para 1 lleva una ip default-gateway pero para 3 ?

    ResponderEliminar
  38. buenos días me sale una alerta en el anti virus que tengo esta una red compartida y muestra un nro Gateway no se si es alguien que me quiere hakear o que alguien sabe

    ResponderEliminar
  39. Buenas tardes.
    quisera saber como puedo bloquear y activar una ip estatica en un switch cisco 2960.
    Gracias

    ResponderEliminar
  40. Puedes usar ACLs, en este articulo lo puedes ver http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_55_se/configuration/guide/scg_2960/swacl.html

    ResponderEliminar
  41. Buenas noches...

    Estoy utilizando GNS3 y requiero colocar port security, entiendo que se hace en el swith y no en el router, ahora la pregunta es ¿como configuro el swith para poder asignarle la ip y poder llegarle por telnet?

    GNS3 me da un ethernet swith sin consola, a diferencia del router que se puede configurar sin problemas...¿como rayos hago eso? si alguno puede ayudarme seria genial que compartieran su experiencia con GNS3, seguramente es algo tonto, sin embargo he trabajo con routers siempre en GNS3.

    Muchas Gracias

    ResponderEliminar
  42. Buen día a todos! Tengo un switch catalyst 2960 y necesito ingresar a el para ver sus configuraciones, pero al momento de ingresar a la IP a otra vez del IE me pide un user y password del cual yo no se. Habra una forma de accesar al switch? Mi conexión al switch es a través de un cable rj45 cat 5 a uno de los puertos PoE del switch.

    Espero puedan comprender lo expuesto y una pronta solución a esto.. gracias!

    ResponderEliminar
  43. Me cago en tos tus muertos, ozea que me pongo io a buscar los comandos encontro esto los meto todoso y no funciona y ahora se a roto el csiso y no puedo arreglar porque ya havia guardado la copia anterior ensima de la que estaba utilizando además de que no explicas usted bien los comandos

    ayudeme arreglar el problema que me a provoado para toda la vida, me la as liao gorda vale? yo lo tenia todo bien configurado y aora me ases esto muerase gordo pendejo

    ResponderEliminar
  44. Hola buenas tardes espero alguien me brinde una pequenia ayuda , tengo una consulta.

    Tengo un router linksys a traves de este router bajo la senial de internet de mi proveedor mi pregunta es puedo conectar mi router linksys al switch cisco 2960 y repartir internet a las demas computadoras conectadas al switch

    ResponderEliminar
    Respuestas
    1. Claro es solo de configurar los puertos gigabit del router y el switch. Debes recordar que habrá que encenderlos porque ellos vienen apagados por default en ambos equipos. Deberas poner la dirección del gateway en el switch con su respectiva máscara de red y listo

      Eliminar